Helper tool stopped working

's Avatar

ingo

13 Apr, 2011 02:32 AM

Hi, eveytime I try to run a scheduled task it says the helper is not installed and when I tell it to install, it doesn't saying there was an error.
When I run it by hand that's what happens:

sudo /Applications/Carbon\ Copy\ Cloner.app/Contents/MacOS/InstallTool cricketbat
usage
FailUrE 22

Thank you

CCC Report ID: 3026

  1. Support Staff 2 Posted by Mike Bombich on 13 Apr, 2011 04:30 PM

    Mike Bombich's Avatar

    Hi ingo:

    Can you try installing it with the attached package and let me know if it works afterwards?

    Thanks,
    Mike

  2. 3 Posted by Ingo Hoffmann on 13 Apr, 2011 04:59 PM

    Ingo Hoffmann's Avatar

    Hi Mike, installed fine but deleted my scheduled tasks, but as soon as I plugged my drive the scheduled task tried to run and got the same error again, trying to install the tool and failing.
    Should I reboot the computer after installing the CCC tools you sent?

    Thanks

  3. 4 Posted by Ingo Hoffmann on 13 Apr, 2011 05:10 PM

    Ingo Hoffmann's Avatar

    Ok, I rebooted the computer. Scheduled task missing.
    When I added the scheduled task and hit save, it says the helper tool is disabled. When I click on Install it says it encountered an internal error.

  4. Support Staff 5 Posted by Mike Bombich on 13 Apr, 2011 09:26 PM

    Mike Bombich's Avatar

    Hi Ingo:

    I ran into a case where this error was particularly persistent not too long ago:

    http://help.bombich.com/discussions/questions/2280-turn-off-donate

    Can you try running the attached AppleScript, then post the resulting debug output back here?

    As far as whether a reboot is necessary after the installer package -- it shouldn't be required. If that error is persistent, though, then something else may be going on. We'll see what the attach script has to say about the status of the installation and go from there.

    Thanks,
    Mike

  5. 6 Posted by Ingo Hoffmann on 13 Apr, 2011 09:29 PM

    Ingo Hoffmann's Avatar

    /dev/disk0s2 on / (hfs, local, journaled) devfs on /dev (devfs, local, nobrowse)
    /dev/disk0s3 on /Volumes/BOOTCAMP (fusefs_txantfs, local, synchronous) map -hosts on /net (autofs, nosuid, automounted, nobrowse)
    map auto_home on /home (autofs, automounted, nobrowse)
    cricketbat
    uid: 0, euid: 0
    launchctl unload -w '/Library/LaunchDaemons/com.bombich.ccc.plist'
    launchctl -> 0 4275 0x0
    mkdir '/Library/PrivilegedHelperTools' 0755 -> 17
    copy '/users/lasombra/Downloads/Applications/InstallToolDebug.app//Contents/Resources/helper_tool' 0755 '/Library/PrivilegedHelperTools/com.bombich.ccc' -> 0
    mkdir '/Library/LaunchDaemons' 0755 -> 17
    copy '/users/lasombra/Downloads/Applications/InstallToolDebug.app//Contents/Resources/com.bombich.ccc.plist' 0644 '/Library/LaunchDaemons/com.bombich.ccc.plist' -> 0
    launchctl load -w '/Library/LaunchDaemons/com.bombich.ccc.plist'
    launchctl -> 0 4276 0x0
    oK

  6. Support Staff 7 Posted by Mike Bombich on 13 Apr, 2011 10:03 PM

    Mike Bombich's Avatar

    The "nobrowse" mount flag on your startup disk is kinda strange... Other than that, the output indicates that the tool was installed and loaded successfully, it all looks fine. Let's try this to see if we can get back on track:

    1. Launch CCC
    2. Open the Scheduler window
    3. Uncheck every saved task, then click the Save button
    4. Recheck each saved task, then click the Save button

    You can wait for the next scheduled task to run naturally, or pick one and click the Run button to test it out. If the "Save" operation works, though, then the "helper_tool" infrastructure parts should be working.

    Mike

  7. 8 Posted by Ingo Hoffmann on 14 Apr, 2011 10:24 PM

    Ingo Hoffmann's Avatar

    Hi Mike,

    I tried the following:

    1. Deleted all scheduled tasks
    2. Selected the directories I wanted to clone on my source disk
    3. Selected the target disk and hit Clone

    After these I was asked for a password, I typed it and got a different error message:
    "An error occurred while attempting to record the exclude rules. Please restart the computer and try again."

  8. Support Staff 9 Posted by Mike Bombich on 15 Apr, 2011 12:21 AM

    Mike Bombich's Avatar

    This is baffling, everything appears to be configured correctly... Let's try another angle. Can you:

    1. Run that InstallToolDebug script again
    2. Run the attached script to enable "deep system debugging"
    3. Launch CCC
    4. Enable debug output via the Help menu
    5. Configure CCC to back something up and click the Clone button
    6. Run the attached script again to disable "deep system debugging"
    7. Attach the resulting debug log on your Desktop to this discussion.

    Hopefully this level of debugging will indicate why your system is rejecting my privileged task...

    Thanks,
    Mike

  9. 10 Posted by Ingo Hoffmann on 18 Apr, 2011 01:53 AM

    Ingo Hoffmann's Avatar

    Hi Mike,

    I had some much issues with my MacBook that something happened that CCC is now working flawlessly again.
    Sorry for all this trouble and thank you so much for your help. Tomorrow I'll donate $20.

    Thank you so much,
    Ingo Hoffmann

  10. Mike Bombich closed this discussion on 18 Apr, 2011 03:00 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac